О программе

О программе MyHomeLib

 Назад Вперед

MyHomeLib - это программа для управления коллекциями электронных книг.

Программа абсолютно бесплатна и имеет открытый исходный код.

Основные возможности

· работа с архивами библиотеки lib.rus.ec
· работа с библиотекой lib.rus.ec в режиме оn-line. В этом случае на компьютере устанавливается только каталог, а книги скачиваются с сайта по мере необходимости.
· экспорт книг в форматах lrf и txt
· автоматическое обновление списков книг lib.rus.ec
· пользовательские коллекции fb2
· автоматический импорт fb2 из папок и zip-архивов
· работа с неограниченным количеством пользовательских коллекций.
· не-fb2 коллекции, возможность работать с любыми типами файлов
· настраиваемые шаблоны имен папок и файлов при экспорте книг из коллекций
· импорт/экспорт коллекций в формате xml
· древовидные списки книг с группировкой по авторам и сериям.
· запуск произвольных скриптов/программ для постобработки и конвертации книг
· создание portable (переносимой) версии

Ссылки

Официальный сайт

Поодержка


ЧАВО

Ответы на часто задаваемые вопросы

Q. Скачал инсталлятор. Не получается установить программу / после инсталляции не получается изменять настройки, добавлять коллекции, пополнять коллекции и т.д.

А. Попробуйте скачать инсталлятор заново (возможно ваша копия плохо скачалась).

Если не помогает, скачайте RAR архив, раскройте его в каком-нибудь месте (НЕ в program files) и запускайте оттуда.

Q. Установил программу, создал коллекцию либрусек. При попытке почитать книгу (отправить на устройстве) получаю сообщение об ошибке "архив не найден"

A. Возможны 2 варианта

а) На компьютере есть архивы либрусека (файлы 1-1001.zip, 1002-2002.zip и т.п.), но неправильно указа путь к папке, в которой они лежат. Зайдите в свойства коллекции и укажите правильны путь к архивам (параметр "Папка с книгами").

б) у вас нет архивов.

В комплекте с программой идут только списки книг, лежащих в архивах. Сами архивы занимают около 12 гигабайт, и, по понятным причинам, распространяются отдельно.

Вы можете скачать их здесь: http://lib.rus.ec/allbooks или на торрент-трекере.

Если вы не хотите качать все сразу, то создайте коллекцию "lib.rus.ec online". Тогда книги будут выкачиваться с сервера по мере необходимости

Q. При попытке почитать книгу, выдается множество сообщений об ошибках

A. MyHomeLib не является читалкой, это только каталог книг. Для чтения книг по-умолчанию используется программа HaaliReader. И эти сообщения показывает именно она. Это означает, что файл, который вы пытаетесь открыть, имеет ошибки в структуре. Попробуйте использовать другую программу для чтения, например, Coolreader.

Q. Я скачал ежедневное обновление книг с либрусека, а программа их не видит

A. Программа работает только со списками архивов, выложенных здесь: http://lib.rus.ec/allbooks Эти архивы обновляются примерно раз в месяц. Списков ежедневных обновлений в программе нет и быть не может.

Q. Так как мне добавить ежедневные обновление?

A. Последовательность действий.

1. Создать пустую коллекцию
2. Указать папку, в которой лежат книги
3. Запустить импорт ("Главное меню"-"Книга"-"Импорт").
4. После добавления новых архивов в папку, запустите импорт еще раз, будут добавлены книги, которых еще нет в коллекции.Создавать новую коллекцию при этом не нужно.

Q. Новых архивов на либрусеке не добавилось, а программа требует обновить списки. Зачем?

А.Благодаря сообществу либрусека, информация о книгах уточняется и дополняется ежедневно, в том числе и информация о книгах, добавленных давно. Поэтому для поддержания актуальности коллекций списки для программы регулярно обновляются. Периодичность этих обновлений никак не связана с выходом новых архивов либрусека.

Q. Как заставить программу сохранять файлы с правильным форматом имени? Пользуюсь lib.rus.ec online, то есть книги загружаю по мере надобности. Загрузил выделенный файл, он сохранился как - К\Камша Вера\Красное на красном.fb2.zip. А хотелось бы как - К\Камша Вера\Отблески Этерны\1_Красное на красном.fb2.zip - такое ощущение, что не отработал %s и %n в формате имени

А. форматирование имени файла происходит только при экспорте на устройство (в папку). Формат имени внутри хранилища lib.rus.ec online не изменяется.


Основные термины

Книга - электронная книга (файл) в любом поддерживаемом формате

Коллекция - все книги, физически расположенные в одной папке на диске. Может содержать не ограниченное количество вложенных папок.

Файл коллекции - файл базы данных с расширением .hlc2 в котором хранится информация о всех книгах коллекции (но не книги!)

Локальное хранилище - папка на диске, в которую записываются файлы, скачанные из он-лайн библиотек. Структура вложенных папок и формат имени файла в хранилище изменять нельзя.


Поддержать разработчиков

Если вам понравилась программа MyHomeLib, вы можете поддержать разработчиков, переведя любую сумму на один из указанных ниже кошельков WebMoney:

Z412971149540

R969568434278

U640460593873

Или через систему PayPal, перейдя на эту страницу: Donate!


Установка

Установка программы

"Чистая установка"

Обновление со старых версий


"Чистая установка"

1. Скачать инсталлятор (или архив)
2. Установить программу (или распаковать архив в произвольную папку)
3. Создать необходимые коллекции
4. Настроить пути к программам для чтения и конвертерам


Обновление со старых версий

1. Перед установкой новой версии сохраните все ваши коллекции (кроме коллекций "lib.rus.ec" и "lib.rus.ec on-line") в формате inpx и пользовательские данные
2. Деинсталлируйте старую версию
3. Проинсталлируйте новую.
4. С помощью мастера создайте коллекции из inpx и импортируйте в них пользовательские данные.


Пользовательский интерфейс

Главное окно

Главное меню

Панель инструментов

Контекстное меню списка книг

Контекстное меню списков авторов/серий/жанров


Главное окно

Главное окно программы состоит из главного меню, панели инструментов, двух алфавитных панелей (русский и латинский алфавиты), информационной панели и шести вкладок, в которых отображаются списки книг.

"Авторы" - на этой вкладке есть два списка - список авторов (слева), и список книг. Эти списки связаны между собой. При выделении автора в левом списке, в правом отображаются все книги этого автора. Над списком авторов расположена форма быстрого поиска - начните вводить в этой форме фамилию, и список будет прокручиваться по мере ввода.

При нажатии на кнопку на алфавитной панели, в списке будут показаны только авторы, фамилии которых начинаются на соответствующую букву.

Кнопка справа от поля "Поиск" очищает его.

"Серии" - аналогично вкладке "Авторы", но с группировкой по сериям.

"Жанры" - аналогично, с группировкой по жанрам. Список жанров может иметь несколько уровней, и его структура зависит от типа файлов активной коллекции (fb2 или не-fb2)

"Поиск" - позволяет искать книги по автору и/или названию.

"Избранное" - здесь показаны книги, добавленные пользователем в избранное.

"Фильтр" - позволяет построить список книг по заданным пользователем критериям.

Вид информационной панели внизу экрана можно настроить: включить/отключить отображение обложки, аннотации, все панели целиком.

Двойной клик на области аннотации переключает режим отображения между "Аннотация" и "Расширенная информация о книге (FB2Info)".

Настроить отображение элементов панели и режим области аннотации можно в меню Вид - Дополнительно


Панель инструментов

Читать - открывает выбранный файл в соответствующей программе

Добавить в список закачки - добавляет все отмеченные книги в список закачки.

Отправить на устройство - экспортирует выбранные файлы на устройство в соответствии с настройками и запускает скрипт по умолчанию (задается в настройках ). В выпадающем списке можно выбрать другой скрипт.

Показать/скрыть русский алфавит

Показать/скрыть английский алфавит

Меню выбора коллекции/Вызов мастера добавления коллекции

Отметить все/Снять снять отметки - отмечает все книги в активном списке

Свернуть/Развернуть список

Обновить - используется после редактирования информации о книгах.

Дерево/Таблица - переключает режим показа списка книг.

Показывать только скачанные - при работе с коллекцией "lib.rus.ec on-line", включает показ только ранее скачанных книг

Показать/Скрыть обложку - доступно только в локальных fb2-коллекциях

Скрывать удаленные - если нажато, то книги, отмеченные на сайте lib.rus.ec как удаленные, не показываются в списке.

Добавить в избранное/Удалить из избранного - добавляет (удаляет) выбранные книги в "Избранное".

Настройки - открывает окно настроек программы.


Горячие клавиши

В списке книг:

Enter - читать книгу

Ctrl+D - отправить на устройство

Ctrl+I - посмотреть информацию о книге

Ctrl+F - добавить в избранное

Ctrl+A - отметить все

Ctrl+U - снять отметки

Ctrl+C - копировать название книги в буфер

Ctrl+Alt+A - перейти к автору

Ctrl + Стрелка влево/Вправо перейти к предыдущему/следующему автору (серии, жанру, группе).


Описание пунктов главного меню

Пункты главного меню

Набор пунктов в меню "Книга" зависит от типа коллекции.

Книга

Коллекция

Группа

Редактирование

Вид

Инструменты

Помощь


Книга

Главное меню. "Книга"

Читать открывает выбранный файл в соответствующей программе

Отправить на устройство экспортирует выбранные файлы на устройство в соответствии с настройками

Добавить в список закачек добавляет выделенные книги в список закачек (вкладка Закачки ). Только для online-коллекций

Прочитано Устанавливает/Снимает отметку о прочтении для выделенных книг

Рейтинг установка рейтинга для выбранных книг

Добавить в избранное

Добавить в группу

Удалить из группы

Копировать в коллекцию копирует выбранные книги в другую коллекцию.

Удалить

Выход


Коллекции

Главное меню. "Коллекции"

Выбрать выбор коллекции. Если создана только одна коллекция, то этот пункт не активен.

Свойства свойства активной коллекции. Позволяет поменять название и путь к папке с книгами.

Статистика - информация о текущей коллекции

Создать создание новой коллекции.

Удалить удаление активной коллекции. Удаляется только внутренняя ссылка на коллекцию, при этом файл коллекции (*.hlc) с диска не удаляется.

Импорт:

Импортировать из xml - загрузка списка книг из xml

Пользовательские данные - загрузка информации о группах, рейтингах, прочитанном

Экспорт

Экспортировать в xml - сохранение информации о книгах активной коллекции в формате xml. Важно! Сохраняется только информация о книгах, а не сами книги!

Экспортировать в inpx - аналогично в формате inpx

Пользовательские данные - сохранение информации о группах, рейтингах, прочитанном. Сохраняет информацию только об активной коллекции!

Обслуживание

Обновить список жанров - структура категорий и жанров заново считывается из файла genres_fb2.lst или genres_nonfb2.lst (в зависимости от типа коллекции). Необходимо после правки списков жанров.

Синхронизировать файлы - синхронизация файлов.


Инструменты

Обновить коллекции - автоматическое обновление списков книг в коллекциях "lib.rus.ec" и "lib.rus.ec-online".


Контекстные меню

Описание контекстных меню

Набор пунктов в контекстном меню зависит от типа коллекции и активной вкладки.

Список авторов/Жанров/Серий

Списки книг


Список авторов/Жанров/Серий

Контекстное меню в списках Авторов/Жанров/Серий

Копировать в буфер - копирует в буфер обмена фамилию и имя автора или название серии или жанра.

Добавить в "Поиск" - в поле Автор на вкладке Поиск добавляется правильно отформатированное условие поиска. Позволяет создавать условия поиска для множества авторов, которое может быть использовано для слежения за новинками.


Списки книг

Контекстное меню в списках книг

Доступность некоторых пунктов меню зависит от активной вкладки и типа активной коллекции.

Читать - открывает выбранный файл в соответствующей программе

Отправить на устройство - экспортирует выбранные файлы на устройство в соответствии с настройками

Информация о книге - вызывает окно с информацией о книге, считанной не из базы, а из fb2-файла. Доступно только в локальных fb2-коллекциях.

Перейти к автору - переход на вкладку "Авторы". При вызове в "Избранном", если книга находится не в активной коллекции, сначала активируется соответствующая коллекция, а потом осуществляется переход.

Изменить описание - взывает диалоговое окно редактирования выбранной книги. Не доступно в коллекциях "lib.rus.ec" и "lib.rus.ec on-line"

Добавить в список закачек - скачивает выбранные книги с сайта lib.rus.ec. Доступно только в коллекции "lib.rus.ec on-line"

Добавить в избранное - добавляет выбранные книги в "Избранное".

Удалить из избранного - удаляет выбранные книги из "Избранного". Доступно только на вкладке "Избранное".

Рейтинг - позволяет установить рейтинг выбранной книги (от 1 до 5)

Выделить все - отмечает все книги в текущем списке

Снять выделение - Снимает все отметки

Копировать в буфер - Копирует информацию о книге в буфер обмена


Работа с коллекциями

Работа с коллекциями

Типы коллекций

Создание коллекци

Параметры коллекций

Импорт книг в формате fb2

Импорт не-fb2 книг

Копирование книг между коллекциями

Удаление коллекций

Импорт/Экспорт коллекции в формате xml


Типы коллекций

Типы коллекций в MyHomeLib

Типы коллекций

1. Коллекции книг в формате fb2 или fb2.zip. Сюда же относятся локальные коллекции lib.rus.ec (USR и AllBooks ). Книги должны храниться локально на компьютере.
2. On-line fb2 - коллекция Lib.rus.ec OnLine [FB2] или Flibusta OnLine [FB2] . Книги скачиваются с сервера библиотеки по мере необходимости, при этом сохраняется локальная копия.
3. Коллекции не-fb2. Могут быть добавлены любые форматы, книги так же храниться локально.

Обратите внимание: Доступность тех или иных пунктов меню зависит от типа коллекции, активной в данный момент.


Добавление коллекци

Главное меню->Коллекции->Создать новую коллекцию

Откроется окно Мастера добавления коллекций, который проведет вас через все необходимые этапы. Набор опций, предоставляемый мастером, зависит от типа создаваемой/добавляемой коллекции.

Новая пустая коллекция - добавление пустой коллекции, в которую потом можно будет скопировать книги из других коллекций или импортировать книги в формате fb2, pdf, djvu, mht и doc.

Существующая коллекция (hlc) ранее созданный файл коллекции с расширением hlc2

Коллекция из файла inpx для создания коллекции используется специальный индексный файл (коллекции библиотек Flibusta, Lubrusec, Traum)

Далее, в зависимости от вашего выбора, мастер предложит указать местоположение файла inpx, или скачать его с сайта, или непосредственно перейти к указанию параметров новой коллекции.

Параметры:

· Название коллекции (произвольное, например, "фантастика");
· Название файла коллекции и папку, где он будет лежать (также могут быть любыми), если указано только имя файла без пути, файл коллекции будет храниться в папке по умолчанию;
· Папка, из которой лежат книги. Если вы планируете заполнять новую коллекцию путем копирования файлов из существующей, то в последнем пункте должен быть указан путь к соответствующей папке. Например, вы хотите создать коллекцию "Фантастика", и скопировать в нее часть книг из раздела "Научная фантастика" коллекции "lib.rus.ec". Тогда укажите папку, в которой лежат архивы либрусека.
· Тип коллекции: fb2 или не fb2 (pdf и д.р.). Будьте внимательны, в последствии тип коллекции изменить нельзя!


Параметры коллекций

Главное меню->Коллекция->Свойства

Этот пункт меню позволяет изменить параметры активной коллекции - название, которое отображается в программе, путь к файлу коллекции, путь к папке с книгами коллекции. Будьте внимательны! Изменение пути к фалу коллекции не меняет положение самого файла! Если вы хотите перенести файл в другое место, сначала скопируйте его с помощью проводника, а затем поменяйте путь к фалу в настройках коллекции.

Для OnLine-коллекций на вкладке Подключение нужно указать имя пользователя и пароль.


Копирование книг между коллекциями

Главное меню->Книга->Копировать в коллекцию

Копирует выделенные книги из активной коллекции в выбранную. Обратите внимание, что копируется только информация о книгах, поэтому в настройках обоих коллекций должна быть указана одна и та же папка с книгами. В противном случае, книги из второй коллекции невозможно будет открыть для чтения или скопировать на устройство.


Удаление коллекций

Главное меню->Коллекция->Удалить

Удаляет активную коллекцию из программы. Сам файл коллекции при этом может не удаляться, и при желании снова добавлен в программу.


Экспорт коллекции в формате inpx

Главное меню->Коллекция->Экспорт ->Экспорт в inpx

Сохраняет данные из активной коллекции в формате xml в указанный файл.

Внимание! Сохраняются только данные о книгах, а не сами книги!


Автоматическое обновление

Главное меню->Инструменты->Обновить коллекции

Будет запущена процедура автоматического обновления тех коллекций, для которых это предусмотрено.

При этом:

1. Проверяется наличие более свежих списков
2. Скачиваются новые списки
3. Старые коллекции удаляются и создаются новые с теми же параметрами на основе новых списков.

Все остальные коллекции и "Избранное" это процедура не затрагивает.


Синхронизация папок/файлов

Главное меню->Коллекции->Инструменты ->Синхронизировать файлы

Доступно в коллекциях lib.rus.ec on-line и пользовательских не-fb2 коллекциях.

1) В OnLine коллекциях

Сканирует папку коллекции и проверяет наличие книг в локальном хранилище. Если файл присутствует, книга в коллекции получает соответствующую отметку.

2) В пользовательской коллекции

Синхронизирует записи о текущем местоположении файлов.

Пример употребления: есть набор pdf файлов, раскиданных по папкам. Все файлы внесены в коллекцию. Вдруг возникает желание разложить файлы внутри папки по-другому, например добавить больше уровней вложения. Раньше это привело бы к неработоспособности коллекции.

теперь раскладываем файлы как угодно, и запускаем синхронизацию (Коллекции - Инструменты - Синхронизировать файлы). Сравниваются имена файлов в базе и размер.

Единственное условие - все действия должны происходить внутри корневой папки коллекции, которая указана в ее свойствах.


Список жанров

Программа позволяет использовать пользовательские списки жанров (для не fb2-коллекций). Количество вложенных уровней не ограниченно. Список жанров в уже созданной коллекции можно изменить в любое время - Коллекция - Обслуживание - Обновить список жанров

Для создания создания своего списка воспользуйтесь любым текстовым редактором, дозволяющим записать простой текст в кодировке UTF-8, например, NotePad ++

Перед созданием списка тщательно продумайте структуру жанров!

1) Создайте новый документ, установите кодировку UTF-8 без BOM

2) Введите разделы первого уровня, каждый в новой строке, нумеруя их по порядку:

0.1 Художественная проза

0.2 Поэзия (стихи и песни)

0.3 Философия, мистика, оккультизм

0.4 Словари, справочники

Внимательно следите за нумерацией. Первое число перед точкой ("0") - это ссылка на родительскую группу. Поскольку мы вводим первый уровень, то здесь стоит ноль. Второе число - номер по порядку внутри текущего уровня.

Продолжаем заполнение:

0.5 Периодические издания

0.6 Hаучн., технич.и уч. лит., метод.пособия

0.7 Вычислительная техника

0.8 Библиографические пособия

0.9 Прочие тексты, не относящиеся к др. разделам

0.10 Картинки и фотографии

0.0 Неотсортированное

Обратите внимание! В списке обязательно должна присутствовать группа 0.0 Неотсортированное

Теперь можно перейти к заполнению нижних уровней. Располагать их в тексте можно в любом месте, после родительского. Например, можно указать все разделы первого уровня, а потом все остальное, или же указывать подуровни сразу. Например:

0.7 Вычислительная техника

0.7.1 Алгоритмы и программирование

0.7.2 Языки программирования

0.7.2.1 Прочие

0.7.2.2 Delphi

0.7.2.3 Pascal

0.7.3 Программы

0.7.3.0 Прочие

0.7.3.1 Графика

0.7.3.2 CAD/CAM

0.7.3.3 Офисные

0.7.4 OC

0.7.4.0 Прочие

После заполнения списка сохраняем его с расширением .glst


Работа с книгами

Добавление книг в коллекцию

Чтение

Экспорт на устройство

Редактирование описаний

Удаление


Добавление книг в коллекцию

Добавление книг в коллекцию

Импорт книг в формате fb2

Импорт не-fb2 книг


Импорт книг в формате fb2

Главное меню->Коллекция->Импорт->

Для коллекций fb2 доступны пункты fb2 из .zip и fb2

fb2 из .zip В текущую коллекцию добавляются все файлы, обнаруженные в папке, указанной в настройках коллекции. Программа просканирует все папки, включая вложенные, и добавит в коллекцию все, что найдет. Количество фалов в архивах и уровней вложения папок - не ограниченны.

fb2 Аналогично предыдущему пункту, добавляются все найденные fb2 файлы.


Импорт не-fb2 книг

Главное меню->Коллекция->Импорт->не-fb2

Откроется окно импорта не-fb2 файлов. Окно состоит из двух основных частей. Вверху - форма для ввода информации о книге, внизу - древовидный список файлов. При вызове этого пункта меню, сканируется содержимое папки с книгами, указанное в свойствах коллекции.

В списке отображаются все найденные файлы, сгруппированные по папкам. Отображаются только файлы тех типов, которые указаны в настройках. Двойной клик в списке открывает соответствующий файл в просмотрщике, который прописан в системе.

Для добавления книги:

· Выбрать книгу (1)
· Название файла будет показано в верхней части окна (2).
· Теперь нужно ввести описание. Это можно сделать, заполнив поля вручную, или выделить отдельные части названия файла и скопировать их в соответствующие поля. Для этого служат маленькие кнопки кнопочки под названием файла (3). Они копируют выделенный текст соответственно в фамилию, имя автора (4), название книги (6) и серию (7). Можно воспользоваться шорткатами Ctrl+Q, Ctrl+A, Ctrl+Z и Ctrl+X соответственно. Обратите внимание, что сначала нужно добавлять фамилию, потом имя, а не наоборот!
· Для добавления/редактирования/удаления авторов (4) используйте соответствующие кнопки в группе "Авторы" (5).
· Если книги относятся к серии, которая уже была добавлена ранее, то название серии можно выбрать из выпадающего списка. Не забывайте указывать номер книги внутри серии.
· Для облегчения ввода большого количества книг, относящихся к одной серии, отключите опцию "Очищать поля" (9). Тогда после ввода очередной книги будет очищаться только поле "Название", а информация об авторах и серии останется, и ее не нужно вводить вручную. Если вы вносите книги по порядку номеров, включите опцию "Увеличивать номер в серии (9)". Тогда после ввода книги номер в поле (7) будет автоматически увеличиваться на единицу.
· Для выбора жанров, нажмите кнопку "..." и в появившемся окне выберите необходимый жанр. Для выбора нескольких жанров одновременно, удерживайте Ctrl.
· Закончив заполнение полей, нажмите кнопку "Добавить" (10). Книга конвертируется в формат FBD и заносится в базу. Имя файла из списка удаляется, список прокручивается на следующую. При повторном сканировании, книги, которые уже занесены в базу, в списке не отображаются. Так что по мере заполнения базы список будет сокращаться.

Если информация об уже добавленных книгах нуждается в корректировке, воспользуйтесь редактированием.


Скачивание книг

Доступно только для on-line коллекций

Отметьте книги, которые вы хотите скачать, галочками. Нажмите кнопку Добавить в список закачки в Панели инструментов (и выберите соответствующий пункт в контекстном меню).

Если включена опция Стартовать закачки автоматически, начнется скачивание книг. Если нет - перейдите на вкладку Список закачек и нажмите кнопку Старт.

Используя кнопки на этой вкладке, вы можете сортировать список, удалять книги из него, приостанавливать и продолжать скачивание. В случае возникновения ошибок, начинается скачивание следующей книги. Книги с ошибкой скачивания перемещаются в конец очереди.

Обратите внимание: Книги сохраняются в папку, указанную при создании коллекции. Формат имени файла внутри этой папки жестко задан и не может быть изменен. Не путайте папку для хранения скачанных книг с папкой для отправки на устройство.


Чтение

Выберите книгу в списке, нажмите 'Enter' (дважды кликните на книге). Книга откроется в соответствующей программе для чтения.


Выделение книг в списке

Все массовые операции с книгами (отправка на устройство, скачивание, копирование) требуют предварительного выделения нужных книг в списке.

В MyHomeLib под выделением подразумевается отметка нужной книги галочкой (см. рисунок).

Выделить одну книгу можно несколькими способами:

· кликнуть на квадратике слева от названия
· нажать пробел
· нажать клавишу Insert , при этом активная книга будет отмечена, а курсор переместится на следующую книгу.

Для выделения всех книг нажмите кнопку Отметить все на панели инструментов или нажмите Ctrl+A

Для того, что бы выделить несколько книг, кликните на первой книге, нажмите и удерживайте клавишу Shift, и кликните на последней книге из тех, которые нужно отметить.

Для того, что бы снять отметки со всех книг, нажмите Ctrl+U


Экспорт на устройство

В данный момент работа с устройствами для чтения сводится к копированию книг в указанную папку или диск (например, на карту памяти, установленную в кардридер).

Параметры экспорта задаются в настройках.

Для экспорта на устройство выберите нужные книги, и нажмите кнопку "Отправить на устройство" на панели инструментов или в контекстном меню.

Если вы хотите обработать или конвертировать экспортируемые книги, выберите соответствующий формат, скрипт или программу в выпадающем меню возле кнопки "Отправить на устройство" или в контекстном меню (см. "Инструкция по добавлению скриптов/программ").


Группы

Функция Группы позволяет создавать мини-подборки книг, например, для того, что бы прочитать их позже. Или перечитать еще раз. При первом запуске создаются 2 служебные группы - Избранное и К прочтению. Эти группы удалить нельзя.

Помимо двух стандартных групп пользователь может создать любое количество собственных групп (кнопка Добавить группу внизу списке). Пользовательские группы можно удалять.

Для добавления книги в группу выберите пункт контекстного меню Добавить в группу и в выпадающем списке выберите группу.

Для добавления в группу избранное выберите пункт Добавить в избранное . Так же можно воспользоваться кнопкой на панели задач для добавления в избранное, или выпадающим списком возле этой кнопки для выбора другой группы.

Для удаления нескольких книг из группы отметьте их и нажмите кнопку Удалить из группы на панели инструментов или пунктом в контекстном меню.

Для удаления всех книг из группы нажмите кнопку Очистить внизу списка книг


Поиск книг

Вкладка "Поиск" позволяет вывести список книг, удовлетворяющих заданным пользователем критериями.

Работает просто - заполняем необходимы поля, нажимаем кнопку Применить.

% обозначает любые символы до или после искомого - например "%нов%" - Иванов, Петров, Сидоров и т.п.

Помимо просто поиска, можно пользоваться языком запросов, используя сложные логические конструкции.

Например, если задать в поле "Имя" запрос LIKE "Аар%" OR "%Александр", в таблице будут показаны все книги, фамилии авторов которых начинающихся на "Аар" или заканчивающихся на "Александр".

Операторы:

LIKE - ищет подобие, при этом

= строгое соответствие

OR AND NOT - логические операторы для объединения условий

> < - "больше","меньше" соответственно.

Допускаются составные операторы, например LIKE "Аар%" OR LIKE "Ра%" или NOT LIKE "Аар%" OR LIKE "Ра%"

Обратите внимание: Искомое значение в тексте запроса должно быть в кавычках " ".

Нюансы:

· Подразумевается, что ФИО автора записано в одной строке целиком. Поэтому если нужен Иванов, запрос должен иметь вид LIKE "Иванов %"
· Если файл запакован, то "Папка/Архив" указывает на файл, если нет - на папку.
· Формат даты зависит от системных настроек. Запрос < "06.12.2008" в поле "Дата" выводит книги добавленные до указанной даты. Диапазоны тоже можно указывать.Пример: > "01.12.2008" - соответственно, после 1-го декабря. > "01.12.2008" AND < "20.12.2008" - между первым и 20-м декабря

Нажатие на кнопку "..." вызывает расширенный редактор запросов.

Обратите внимание: Кнопки в верхней части редактора служат для вставки шаблонов в позицию курсора.

Готовые наборы параметров поиска (пресеты) можно сохранить и в последствии использовать снова. Для сохранения пресета введите название (любое) и нажмите Сохранить пресет. Для загрузки ранее созданного пресета выберите его в выпадающем списке.

Можно использовать неограниченное количество пресетов. Для удаления пресет нажмите кнопку Удалить пресет.


Удаление

Главное меню->Книга->Удалить

Удаляет выбранные книги из активной коллекции. Для некоторых типов коллекций (коллекции lib.rus.ec) удаление книг заблокировано.

Обратите внимание, что удаляется только ссылка и информация о книге. Сами файлы с книгами остаются на месте. Если вы хотите удалять файлы книг вместе с записью в базе, включите соответствующий пункт в настройках (вкладка Разное)


Редактирование описаний книг

Обратите внимание: Редактирование не доступно в коллекциях "lib.rus.ec" и "lib.rus.ec on-line".

Автор

1. Редактирование Ф.И.О. автора. Затрагивает все книги данного автора. Выделяем одну книгу (любую), Правим ФИО. Галочки не ставим!
2. Изменение автора книги. Отмечаем нужные книги галочками. Книга - Редактировать - Автор. Вводим ФИО. Если отмечено "Новый автор" - все отмеченные книги переедут к новому автору. Если отмечено "Сохранять связи", у книги добавится еще один автор.

Жанры

Изменение списка жанров всех отмеченных книг

Серия

1. Выделяем серию в списке книг. Книга - Редактировать - Серия. Правим название серии.
2. Отмечаем книги. Книга - Редактировать - Серия. Вводим серию, к которой нужно отнести книги, новую или существующую. отмеченные книги поедут в указанную серию.

Описание Редактирование информации о выделенной книге.

Обратите внимание: Если изменить название серии в этом окне, будет создана новая серия с заданным названием.


Настройки

Настройки

Интерфейс

Программы для чтения и типы файлов

Настройки экспорта на устройство

Интернет

Скрипты

Разное


Интерфейс

Главное меню->Книга->Настройки, Вкладка Интерфейс.

Здесь можно выбрать размер шрифта для списков и аннотаций, настроить цвета в списках авторов, жанров, серий и книг.


Типы файлов и программы для чтения

Главное меню->Книга->Настройки, Вкладка Типы файлов.

(1) Здесь перечислены типы файлов, которые будут распознаваться программой при импорте в не-fb2 коллекции (поддержка файлов fb2 и fb2.zip включена по умолчанию) и программы, которые будут вызываться для просмотра соответствующих файлов.

Если указано только расширение, то будет вызываться программа, зарегистрированная в Windows по умолчанию для данного типа файлов. В случае fb2, по умолчанию запускается HaaliReader.

Если вы не хотите использовать программу по умолчанию (на примере fb2):

1. Нажмите кнопку добавить (2). В появившемся окне укажите добавляемое расширение (в нашем случае, fb2).
2. Теперь нужно указать путь к программе для чтения (4). Нажмите кнопку "..." и в диалоговом окне укажите соответствующий путь.
3. Сохраните изменения.


Настройки экспорта на устройство

Главное меню->Книга->Настройки, Вкладка Папки/Устройства

· Укажите путь к папке на устройстве (к карте памяти в кардридере), куда будут экспортированы выбранные файлы (1). Для этого нажмите кнопку ... и выберите нужную папку. Если отметить пункт Спрашивать путь каждый раз, при каждом вызове отправки на устройство будет выводится диалог выбора папки.
· Выберите формат записи fb2-файлов на устройство (2). Не-fb2 файлы копируются "как есть".

Для экспорта в форматы epub, pdf и mobi необходимо скачать соответствующие конвертеры и распаковать их файлы в папку converters внутри рабочей папки программы, например C:\Program Files\MyHomeLib\Converters\fb2Epub\

· Настройте шаблоны имен папок и файлов (3). Например, шаблон папки %f\%s указывает, что в папке на устройстве будет создана папка с именем автора, а в ней - папки с названиями серий. Если книга не относится к серии, то параметр %s игнорируется.

Шаблон имени файла %n%t указывает, что имя файла будет состоять из номера в серии (если он есть), и названия книги.

Например, для приведенных выше шаблонов, имена файлов будут иметь вид:

E:\temp\А Котенко\Двойная игра.94238.fb2.zip (книга без серии)

E:\temp\А Котенко\Архивы О.С.Я\01- Каникулы на халяву или реалити-шоу для Дурака.94253.fb2.zip

E:\temp\А Котенко\Архивы О.С.Я\02- Мыльная сказка.94015.fb2.zip (книги в серии)

· Если у вашего устройства проблемы с отображением кириллицы в именах файлов, включите опцию транслитерации. Для этого нужно переписать шаблон (весь или его часть) заглавными буквами, например %N%T
· Опция "включить фильтр [...]" удаляет квадратные скобки и текст между ними из имени файла. Например, если в коллекции название книги Вслед за черной королевой [= Вслед за Красной Королевой], файл будет называться Вслед за черной королевой
· Вы можете указать кодировку текстовых файлов - UTF-8 или Windows 1251


Интернет

Настройки подключения к интернету

Главное меню->Книга->Настройки, Вкладка Интернет.

1) Сервер lib.rus.ec - адрес библиотечного сервера. Помимо http://lib.rus.ec , это может быть сервер MyNetLib или зеркало либрусека.

2) Настройки прокси - есои вы подключены к интернету через прокси сервер (например, к корпоративной сети), укажите адрес сервера, порт (обычно 8080), имя пользователя и пароль.

3) Сервер обновлений - адрес, по которому проверяется наличие новых версий программы, а так же обновление списков для коллекций lib.rus.ec.

Первый пункт включает проверку новых списков для коллекций при запуске, второй - обновления программы.


Скрипты

Главное меню->Книга->Настройки, Вкладка Скрипты.

(1) Здесь перечислены скрипты и внешние программы, которые будут вызываться после экспорта книг из коллекции в указанную папку.

Пример: обработка книг с помощью fb2fix

1. Нажмите кнопку добавить (2). В появившемся окне укажите понятное название, которое будет отображаться в меню (например, "Fb2 ==>Fb2Fix" ) (3)
2. Теперь нужно указать путь к программе (4). Нажмите кнопку "..." и в диалоговом окне укажите соответствующий путь.
3. Укажите параметры командной строки (если необходимо). Например, /output:"E:\out" E:\Temp (5)
4. Выберите, какой скрипт будет запускаться по-умолчанию при нажатии на кнопку или выборе пункта меню Отправить на устройство. Стандартное действие - файлы просто копируются в указанную папку.
5. Сохраните изменения (7).

При разработке макросов можно использовать следующие переменные, передаваемые в командную строку:

· %TMP% - передает путь временной папки, куда MyHomeLib распаковывает книги
· %DEST% - путь к папке на устройстве
· %NFT% - сбрасывает шаблон имени папки, все файлы валятся в одну кучу
· %FOLDER Имя папки% - заменяет дефлотный каталог экспорта на Имя папки, но сам в командную строку не выводится. т.е. можно для разных скриптов задать разные выходные папки

Команда %COPY% вместо имени исполняемого файла копирует файлы в папку, указанную в "Параметрах".

Примеры:

Название | Путь | Параметры | Действие
Послать на | %COPY% | E:\Temp | копирует выбранные книги в папку E:\Temp
Конвертировать | D:\some_util.exe | "%FILENAME%" | запускает внешнюю программу и передает ей имена файлов


Разное

Показывать книги из вложенных жанров (не fb2) - при выборе родительского уровне в списке жанров будут выводиться все книги из выбранного жанра и поджанров.

Сворачивать в трей - свернуть программу в трей

Стартовать закачки автоматически - закачка книг начинается сразу при добавлении их в список закачки. Если при запуске программы есть незавершенные закачки, они будут продолжены автоматически.

Перезаписывать заголовок fb2 - при отправке fb2 файла на устройство, заголовок файла будет перезаписан в соответствии с информацией из БД

Разрешить смешанные коллекции - позволяет импортировать в одну пользовательскую коллекцию как fb2 файлы, так и файлы других форматов.

Удалять "Удаленные в библиотеке" - при синхронизации файлов online коллекции, ранее скачанные книги, имею отметку "Удалено на либрусеке", будут удалены из хранилища.


Примеры скриптов

Примеры пользовательских скриптов, которые можно запускать после экспорта книг в папку/на устройство. (из форума поддержки MyHomeLib).


Конвертация fb2 файлов в wolf

Автор: 1_абрам

При отправке выбранных книг на устройство фб2 файлы конвертируются в wol и сохраняются в директории D:\lib

Для конвертации используется CoolReader3 (cr3).

1) Создаем файл 2wolf.bat

rem @echo off

d:

cd d:\lib\1

for /r %%i in (*.fb2 *.zip) do (

rem @echo disk= %%~nsi

D:\prg\cr3\cr3.exe %%i --convert --format=wol --out=d:\lib\%%~ni.wol >nul 2>&1

if errorlevel 1 (

echo %%i FAIL >> 1rez-FAIL

) else (

echo %%i PASS >> 1rez-PASS

)

)

del /S /Q *.*

rd /S /Q d:\lib\1

2) Настраиваем MyHomeLib:

"Главное меню"->"Книга"->"Настройки", Вкладка "Папки/Устройства"

Папка на устройстве

D:\lib\1

"Главное меню"->"Книга"->"Настройки", Вкладка "Скрипты"

Подключаем наш скрипт:

Название Путь Параметры

FB2->WOL D:\prg\MyHomeLib_9_5\2wolf.bat


Подключение Fb2Fix

Автор: Sk0rp

Скрипт для Fb2fix, позволяющий проверить и исправить сразу все книги библиотеки на предмет валидности FB2 (с форума The Ebook):

@echo off

set tmpout=%~f4

if #%tmpout%#==## set tmpout=%TEMP%\fb2fix

md "%tmpout%\tmp" 2>NUL

set fb2fix=%~f1

set z7=%~dp17z.exe

set outdir=%~f3

md "%outdir%" 2>NUL

cd %2

FOR /D %%D IN (*.*) DO call :nextdir "%%~nxD"

goto :EOF

:nextdir

echo Folder: %~1

md "%outdir%\%~1" 2>NUL

FOR /D %%D IN ("%~1\*.*") DO call :nextdir "%~1\%%~nxD"

FOR /F "tokens=* delims=" %%N IN ('dir "%~1\*.*" /B /A-D') DO call :convert "%~1\%%~N" "%~1" "%%~N"

rd "%~1" 2>NUL

goto :EOF

:convert

echo "%~f1"

del /F /S /Q "%tmpout%\*.*" >NUL

%fb2fix% /compress- /translify- "%~f1" /output:"%tmpout%" >NUL

IF EXIST "%tmpout%\Good\*.fb2" (

move "%tmpout%\Good\*.fb2" "%tmpout%\tmp\%~n3" >NUL

) ELSE (

move "%tmpout%\Bad\*.fb2" "%tmpout%\tmp\%~n3" >NUL

)

IF NOT %errorlevel%==0 goto :EOF

rem del /F /Q "%~f1"

"%z7%" a -tzip -mx7 "%outdir%\%~2\%~n3.zip" "%tmpout%\tmp\%~n3" >NUL

Скопировать и вставить например в script.bat

Параметры запуска:

script.bat <ссылка на fb2fix> <начальная папка> <папка для обработанных> [<временная папка>]

Пути могут быть как относительными так и абсолютными.

В папку где лежит fb2fix.exe нужно скопировать 7z.exe

Что скрипт делает:

Запускает fb2fix для каждого файла, затем восстанавливает его начальное имя и реплицирует изначальную структуру папок.

Это надо для того, что бы последующие обновления Traum Library, которые выходят на уровне файлов могли нормально применяться к ранее обработанной библиотеке. (Обновления перед копированием в библиотеку заранее прогнать этим же скриптом).

Четвертый параметр скрипта нужно указывать если вы хотите одновремено запустить несколько копий скрипта, соответственно у каждой копии должна быть своя временная папка.

У меня, например, ядер в процессоре много, несколько параллельно работающих копий существенно быстрее справляются, чем одна.

Примеры:

script.bat FB2Fix.exe D:\Library\ru\_ outlib\_ tmp1

- script.bat лежит в той же папке, что и FB2Fix, соответственно перерабатывает D:\Library\ru\_, результат складывает в в эту же папку в подпапку outlib\_, как временная папка используется созданная здесь же tmp1.

script.bat D:\fb2fix\FB2Fix.exe E:\ D:\Library

- где лежит script.bat не важно, перерабатывает E:\, результат в D:\Library\, FB2Fix распакован соответственно в D:\fb2fix\, туда же скопирован 7z.exe. Так, например, можно взять библиотеку непосредственно с подмонтированного диска с Traum Library.

script.bat FB2Fix.exe D:\Library D:\Library

- Обработка папки D:\Library с библиотекой. Результат остается тут же.

Если обработанные файлы больше не нужны, раскоментируйте строчку "del /F /Q "%~f1"", тогда после обработки начальный файл будет удаляться.

Добавлено:

При копировании текста скрипта с форума MS Internet Explorer'ом и браузерами на их основе, в конец каждой строки добавляются пробелы. В исходном тексте html этих пробелов нет, т.е. IE их полностью придумывает.

В bat файлах пробелы значимы, в частности в текущем случае они залезают в середину имен файлов, после чего скрипт перестает работать.

Если у кого-то сходные проблемы, то поставьте наконец Firefox...


Создание Portable - версии

1. Положить папку с книгами в папку программы. Например, MyHomeLib\Books
2. Создать рядом с файлом MyHomeLib.exe пустой файл uselocaldata
3. Запустить Мастер создания коллекции
4. В свойствах новой коллекции указать файл коллекции без пути, только имя , относительный путь к папке с книгами. В нашем случае, Books
5. Закончить создание коллекции

Настройка читалок

1. Переносим читалки в папку MyHomeLib\Readers
2. В настройках читалок изменяем пути на относительные, например Readers\haalireader.exe

Все. Можно скинуть папку MyHomeLib на внешний диск и носить с собой.